Shipfix performance degradation

Incident Report for Veson

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 12:03 EDT

Update

We are experiencing a load-related outage. The underlying issue has been identified and the team is working to resolve the situation as quickly as possible.
Posted Mar 26, 2025 - 10:58 EDT

Identified

Users may continue to experience degraded performance while improvements are implemented
Posted Mar 26, 2025 - 10:47 EDT

Monitoring

A fix has been implemented, which largely addresses the performance issue described. Additional performance improvements are scheduled to be released later today
Posted Mar 26, 2025 - 09:47 EDT

Identified

Some users may be experiencing performance degradation. This issue has been identified and the team is working on a fix.
Posted Mar 26, 2025 - 08:21 EDT
This incident affected: Shipfix (Email Inbound, Email Outbound, Market Monitor, Data Insights, Vessel & Port Directory).