Q88 Web Application - Service degraded

Incident Report for Veson

Resolved

This incident has been resolved and Q88 Web Application is operating within normal parameters.
Posted May 05, 2025 - 08:57 EDT

Monitoring

A fix has been implemented and we are monitoring.
Posted May 05, 2025 - 07:54 EDT

Investigating

We are aware that some customers are experiencing service degradation within the Q88 Web Application. We are actively investigating the issue and will update when we have further details.
Posted May 05, 2025 - 07:06 EDT
This incident affected: Q88 (Q88).