Snowflake's incident has been resolved, and we have confirmed queries are working and changes are being processed for Snowflake-based Data Lake environments in the US.
Posted Oct 20, 2025 - 18:28 EDT
Update
Snowflake queries are now succeeding intermittently, and incoming data from IMOS Platform is being processed in some cases. We are continuing to monitor the incident and will advise when service is completely recovered.
Posted Oct 20, 2025 - 13:31 EDT
Update
The Snowflake incident has increased in severity, and customers may not be able to query their Data Lake instances hosted in the US Snowflake region. We are continuing to monitor the situation.
Posted Oct 20, 2025 - 10:20 EDT
Monitoring
We are aware that some customers may be experiencing delays in receiving updates in their Snowflake-based Data Lake environments located in the US. This is caused by service issues at Snowflake related to widespread Amazon issues today, and is being tracked by Snowflake in https://status.snowflake.com/incidents/gvmvnx7lyxjj. We are actively monitoring the issue and will update when we have further details.
Posted Oct 20, 2025 - 09:11 EDT
This incident affected: IMOS Platform (Data Lake).