Degraded performance for mailboxes connected using Imap

Incident Report for Veson

Resolved

The issue was identified and has been fixed. Impacted clients should see service return to normal.
Posted Aug 14, 2025 - 07:42 EDT

Investigating

We are aware of some slowness in receiving emails on mailboxes connected using IMAP. Our team is currently investigating.
Posted Aug 14, 2025 - 06:51 EDT
This incident affected: Shipfix (Email API, Email Inbound, Email Outbound, Email Processing).