IMOS Platform Web Application - Service degraded for some EU customers

Incident Report for Veson

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 13:46 EDT

Monitoring

The service impact has subsided and we are monitoring.
Posted Jun 02, 2026 - 09:45 EDT

Investigating

We are aware that some customers in the European Union (EU) region are experiencing service degradation within the IMOS Platform Web Application. We are actively investigating the issue and will update when we have further details.
Posted Jun 02, 2026 - 09:35 EDT
This incident affected: IMOS (Web Application).