IMOS Platform Messaging Service - Delayed outbound email delivery in US region

Incident Report for Veson

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 12:21 EDT

Monitoring

A fix has been implemented and we are monitoring the situation. Outbound email delivery has resumed. Email sent via the messaging service between 4:00 UTC and 16:04 UTC may have failed delivery. Please reach out to Veson Support if you need assistance re-sending email.
Posted Sep 15, 2026 - 12:18 EDT

Identified

We are aware that some customers may be experiencing delayed outbound email notification delivery within the IMOS Platform Messaging Service. We are actively investigating the issue and will update when we have further details.
Posted Sep 15, 2026 - 11:48 EDT
This incident affected: Veson Platform (Web Application) and IMOS (Messaging Services).