Microsoft Exchange Online outage impacting both inbound and outbound email

Incident Report for Veson

Resolved

We're no longer seeing issues on the Microsoft side, and all pending emails have now been processed.
Posted Sep 01, 2026 - 03:09 EDT

Monitoring

Microsoft confirms that mail flow is working as expected. We are monitoring the situation
Posted Sep 01, 2026 - 01:31 EDT

Update

We are continuing to monitor Microsoft Exchange Online status page and we will provide update as soon as possible
Posted Aug 31, 2026 - 18:09 EDT

Identified

We are monitoring Microsoft Exchange Online status page and we will provide update as soon as possible
Posted Aug 31, 2026 - 17:32 EDT

Investigating

Customers may experience delays in receiving emails or failures when sending them due to an ongoing Microsoft Exchange Online incident
Posted Aug 31, 2026 - 16:30 EDT
This incident affected: Shipfix (Email Inbound, Email Outbound).