Shipfix: Downgraded performance of Inbound emails

Incident Report for Veson

Resolved

The Microsoft API has recovered, and the Shipfix platform is operating under normal conditions
Posted Jan 08, 2026 - 09:42 EST

Update

Microsoft API performance has returned to normal, and the Shipfix platform is rapidly processing the backlog of emails.
Posted Jan 08, 2026 - 09:21 EST

Update

Microsoft API performance remains in a degraded state, which is impacting email delivery. Veson is monitoring the situation closely, and has escalated to Microsoft. Microsoft have acknowledged the problem and their backend team are working on it.
Posted Jan 08, 2026 - 08:51 EST

Update

Microsoft API performance remains in a degraded state, which is impacting email delivery. Veson is monitoring the situation closely, and has escalated to Microsoft.
Posted Jan 08, 2026 - 08:49 EST

Identified

Performance is starting to improve now, and we are slowly recovering the delay
Posted Jan 08, 2026 - 05:49 EST

Update

The incident is still in progress. The issue is related to Microsoft API performance.
Posted Jan 08, 2026 - 04:48 EST

Investigating

We are receiving some emails from Outlook with delays
Posted Jan 08, 2026 - 03:55 EST
This incident affected: Shipfix (Email Inbound).