Veslink Voyage Reporting Forms Unavailable

Incident Report for Veson

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 13:01 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 12:56 EST

Investigating

We are aware that customers are unable to load voyage reporting forms submitted through Veslink Voyage Reporting, and may have issues loading the Veslink Voyage Reporting interface as well. We are actively investigating the issue and will update when we have further details.
Posted Dec 05, 2025 - 12:50 EST
This incident affected: IMOS Platform (Web Application, Veslink Voyage Reporting).